Perl DBD::mysql模块缓冲区溢出漏洞

  • A+
所属分类:cnnvd_vulns

漏洞信息详情

Perl DBD::mysql模块缓冲区溢出漏洞

  • CNNVD编号:CNNVD-201610-112
  • <!--

  • 危害等级: 中危-->
  • 危害等级: 中危
    Perl DBD::mysql模块缓冲区溢出漏洞

  • CVE编号:
    CVE-2016-1246

  • 漏洞类型:

    缓冲区溢出

  • 发布时间:

    2016-10-10

  • 威胁类型:

    远程

  • 更新时间:

    2016-10-10

  • 厂        商:

    debian
  • 漏洞来源:

漏洞简介

Perl是美国程序员拉里-沃尔(Larry Wall)所研发的一种免费且功能强大的跨平台编程语言。DBD::mysql是用于其中的一个MySQL的Perl5数据库接口(Database Interface,DBI)驱动模块。

Perl DBD::mysql模块4.037之前的版本中存在缓冲区溢出漏洞。上下文相关的攻击者可利用该漏洞造成拒绝服务(崩溃)。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:

http://blogs.perl.org/users/mike_b/2016/10/security-release---buffer-overflow-in-dbdmysql-perl-library.html

参考网址

来源:github.com

链接:https://github.com/perl5-dbi/DBD-mysql/commit/7c164a0c86cec6ee95df1d141e67b0e85dfdefd2

来源:DEBIAN

链接:http://www.debian.org/security/2016/dsa-3684

来源:blogs.perl.org

链接:http://blogs.perl.org/users/mike_b/2016/10/security-release---buffer-overflow-in-dbdmysql-perl-library.html

来源:packetstormsecurity.com

链接:http://packetstormsecurity.com/files/138942/Debian-Security-Advisory-3684-1.html

来源:www.auscert.org.au

链接:http://www.auscert.org.au/./render.html?it=39214

受影响实体

  • Debian Debian_linux:8.0  

    <!--

    2000-1-1

    -->

补丁

  • Perl DBD::mysql模块缓冲区溢出漏洞的修复措施

    <!--

    2016-10-10

    -->

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 我的微信公众号
  • 我的微信公众号扫一扫
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: