Ruby openssl gem 加密问题漏洞

  • A+
所属分类:cnnvd_vulns

漏洞信息详情

Ruby openssl gem 加密问题漏洞

  • CNNVD编号:CNNVD-201609-578
  • <!--

  • 危害等级: 高危-->
  • 危害等级: 高危
    Ruby openssl gem 加密问题漏洞

  • CVE编号:
    CVE-2016-7798

  • 漏洞类型:

    加密问题

  • 发布时间:

    2016-09-26

  • 威胁类型:

    远程

  • 更新时间:

    2020-11-10

  • 厂        商:

    ruby-lang
  • 漏洞来源:
    Mike Santillana

漏洞简介

Ruby是日本软件开发者松本行弘所研发的一种跨平台、面向对象的动态类型编程语言。Ruby openssl gem是其中的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库。

Ruby openssl gem中存在安全漏洞。攻击者可利用该漏洞绕过加密保护机制。

漏洞公告

目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页:

http://www.ruby-lang.org/zh_cn/

参考网址

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2016/10/01/2

来源:CONFIRM

链接:https://github.com/ruby/openssl/issues/49

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2016/09/30/6

来源:BID

链接:https://www.securityfocus.com/bid/93031

来源:MLIST

链接:http://www.openwall.com/lists/oss-security/2016/09/19/9

来源:CONFIRM

链接:https://github.com/ruby/openssl/commit/8108e0a6db133f3375608303fdd2083eb5115062

来源:DEBIAN

链接:https://www.debian.org/security/2017/dsa-3966

来源:MLIST

链接:https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html

来源:BID

链接:http://www.securityfocus.com/bid/93031

受影响实体

  • Ruby-Lang Openssl:2.3.1  

    <!--

    2000-1-1

    -->

补丁

  • Ruby OpenSSL Library 安全绕过漏洞的修复措施

    <!--

    2016-9-26

    -->

  • 我的微信
  • 这是我的微信扫一扫
  • weinxin
  • 我的微信公众号
  • 我的微信公众号扫一扫
  • weinxin

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: